読者です 読者をやめる 読者になる 読者になる

JBoss-5.0.1GA, JDK1.6, JBossSeam-2.1.2GA を使ってみた

前のエントリ (http://d.hatena.ne.jp/aaabbb_200904/20090816/1250412026 ) でJBoss-5.0.1GAをインストールした際、Seam のサンプルが上手く動かなかったのだが、Seamのサイトで確認したところ、Seam-2.0系列は、JDK1.6で上手く動作しないらしい。

このため、Seam-2.1.2GAを新たにダウンロードし、JBoss-5.0.1GA, JDK-1.6で動くかどうか確認してみた。 (JDKとしては RPM版の jdk-1.6.0_16-fcs.x86_64 を使用) ビルド手順は以前と同じである。
http://d.hatena.ne.jp/aaabbb_200904/20090620/1245492119


結果としては、todo, booking で確認し、どちらも上手く動作した。JBoss, JDK, Seam, Messaging などそれぞれに依存性があるので、確認が大変だが、できる限りEAPと合わせて構成することで問題を回避できるとよさそうだ。。